[Zope-DB] Transaction Weirdness

Christian Theune ct at gocept.com
Sun Sep 14 18:29:09 EDT 2003

Am So, 2003-09-14 um 21.46 schrieb Dieter Maurer:
> Turned out that both of us made the same error:
>   We both worked on an object relational mapping.
>   In order not to write the database for each modified
>   attribute, we delayed writing to the database until
>   commit.
>   At that time, however, the transaction had already
>   determined all objects that should take part in the
>   transaction. The PostgresDA registered too late and
>   was "forgotten".
> Not sure, you see the same problem.

Hmm. We aren't doing that. Only standard Z SQL Methods using pypgsql.
Maybe they do something weird, but I already went through all the
transaction hooks with a debugger. Gonna check this out tomorrow with a
colleague again. If we discovering something bad to look out for, I'll
post it back here.

> Aside from this error on our part, we never lost commits to
> Postgres.

You're on the good side of life. :)

Thanks for posting,

Christian Theune, gocept gmbh & co. kg
http://www.gocept.com - ct at gocept.com
fon: 03496 3099112 fax: 03496 3099118 mobile: 0179 7808366
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : http://lists.zope.org/pipermail/zope-db/attachments/20030915/d48978e4/attachment.bin

More information about the Zope-DB mailing list