[Zope-DB] Re: Form evaluation in ZSQL-Method

Andreas Tille tillea at rki.de
Fri Sep 19 05:58:36 EDT 2003

On Thu, 18 Sep 2003, Dieter Maurer wrote:

>  >        Missing input variable, iditem
>  >
>  > Any hint what's wrong here or rather, how to do this right?
> You link must contain the query parameters...
I rather suspect a much more deeper problem, perhaps a bug in my Zope
implementation.  I just created a simple database using the following script:


   createdb $DBNAME
   psql $DBNAME <<...
   CREATE TABLE test (
     iditem int         NOT NULL,
     item   varchar(32) NOT NULL
   ) ;
   GRANT ALL ON test TO zope;

   while [ $i -lt 30 ] ; do
      item="item $i"
      echo "INSERT INTO test VALUES ($i, '$item');" | psql $DBNAME

(or just use an existing database).  Then I created a Database Connection
Object and connected it to this database and tried the Test tab. A

     select * from test

brings up the first 20 items as expected but the Link "Next 10 results" (which
is pointing to:



   Site Error

   An error was encountered while publishing this resource.

   Invalid request
   The parameter, query, was omitted from the request.

   Make sure to specify all required parameters, and try the request again.

I'm using Zope 2.6.1 on Debian GNU/Linux (Testing) and as DB-Adapter
zope-psycopgda version

I'm sure this worked with previous installations and I'm going to verify other
installations.  Any hint what might went wrong here?

Kind regards


More information about the Zope-DB mailing list