[Zope-DB] MS SQL stored procedures and MXODBCDA - supposedly NO RESULTS

Peter Millar peter.millar at parasyn.com.au
Sun Jun 27 20:16:33 EDT 2004

How come when I run my stored procedure from the query analyzer I get a
swag of results but if I run it from zope I get no results returned.  

Is it because the odbc driver or zsql cannot handle such a simple stored
procedure as this one where a temporary table is created, populated,
queried, and finally dropped.

@StartDate DateTime, 
@EndDate DateTime, 
@Name varchar(256)

--Create a temporary table containing the history data
CREATE TABLE #DisAgg (name varchar(256), dt datetime, value int)
 SELECT name, DateTime, Value
  FROM y

b.dt as enddate, 
FROM #DisAgg b 
WHERE b.value = 0

--Drop temporary tables
Drop table #DisAgg

Peter Millar 
Technical Project Manager 
Parasyn Controls Pty Ltd 

Peter.Millar at Parasyn.com.au 
T: 61 7 3396 6388 
F: 61 7 3396 6299 
45 Millenium Place, Tingalpa QLD 4173 
PO Box 400 Cannon Hill QLD 4170 
www.parasyn.com.au <http://www.parasyn.com.au/>  

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.zope.org/pipermail/zope-db/attachments/20040628/9c9d4b2d/attachment.htm

More information about the Zope-DB mailing list