[Zope-DB] Re: Database Corruption (1 possible solution)

Eugene el-spam at yandex.ru
Wed Jun 30 04:39:24 EDT 2004

Hello Nick,

I guess in your case error was in DB index. Zope lookups for object in
the index and then tried to access in DB, but there was no this object
- so it raises error.
Then you delete this files, zope recreated correct index from scratch.

NB> The solution was to remove the Data.fs.index and Data.fs.tmp files and
NB> let ZODB rebuild them on startup.  Why this worked I have no idea (it
NB> was a stab in the dark at the time) as I don't know much about ZODB
NB> internals.  However, this happened to us twice in a single week (which
NB> on it's own is quite sad).

NB> Ramon Aseniero wrote:
>> Hi All,
>> Is there a way to prevent the Zope database from being corrupted?
>> Thanks,
>> Ramon
>> ------------------------------------------------------------------------
>> _______________________________________________
>> Zope-DB mailing list
>> Zope-DB at zope.org
>> http://mail.zope.org/mailman/listinfo/zope-db

NB> _______________________________________________
NB> Zope-DB mailing list
NB> Zope-DB at zope.org
NB> http://mail.zope.org/mailman/listinfo/zope-db

Best regards,
 Eugene                            mailto:el-spam at yandex.ru

More information about the Zope-DB mailing list