[Zope-DB] Re: Database Corruption (1 possible solution)

Jim Fulton jim at zope.com
Wed Jun 30 09:57:55 EDT 2004

Nick Bower wrote:
> I was going to post this tip on it's own, but seeing how it's relevant 
> to the current discussion, I'll post it here.
> Recently we've been having "read conflict errors" preventing Zope from 
> connecting to a ZODB on startup in a ZEO deployment.  (Moving the 
> Data.fs* to a standalone non-ZEO configuration made no difference).
> Upon a little digging, I found an error relating to an illegal attempted 
> reassignment of an oid.
> I tried the recovery tools, but these did nothing.
> The solution was to remove the Data.fs.index and Data.fs.tmp files and 
> let ZODB rebuild them on startup.  Why this worked I have no idea (it 
> was a stab in the dark at the time) as I don't know much about ZODB 
> internals.  However, this happened to us twice in a single week (which 
> on it's own is quite sad).

Did you report this to either the zodb-dev list or to the
zodb bug tracker?


Jim Fulton           mailto:jim at zope.com       Python Powered!
CTO                  (540) 361-1714            http://www.python.org
Zope Corporation     http://www.zope.com       http://www.zope.org

More information about the Zope-DB mailing list