[Zope-DB] Re: Database Corruption (1 possible solution)

Nick Bower nicholas.bower at jrc.it
Wed Jun 30 13:47:59 EDT 2004

Nope - the genericness of the reported error in event.log and many other 
frustrated posts of users in lists/web pages experiencing similar things 
(during frantic google searching) led me to believe ZODB problems like 
this are commonplace.

I'll see if I can dig up a log then.  The log was not particularly 
descriptive however as the problem happened on a production ZEO platform 
both times with logging turned down.

Jim Fulton wrote:
> Nick Bower wrote:
>> I was going to post this tip on it's own, but seeing how it's relevant 
>> to the current discussion, I'll post it here.
>> Recently we've been having "read conflict errors" preventing Zope from 
>> connecting to a ZODB on startup in a ZEO deployment.  (Moving the 
>> Data.fs* to a standalone non-ZEO configuration made no difference).
>> Upon a little digging, I found an error relating to an illegal 
>> attempted reassignment of an oid.
>> I tried the recovery tools, but these did nothing.
>> The solution was to remove the Data.fs.index and Data.fs.tmp files and 
>> let ZODB rebuild them on startup.  Why this worked I have no idea (it 
>> was a stab in the dark at the time) as I don't know much about ZODB 
>> internals.  However, this happened to us twice in a single week (which 
>> on it's own is quite sad).
> Did you report this to either the zodb-dev list or to the
> zodb bug tracker?
> Jim

More information about the Zope-DB mailing list