[Zope-DB] Problem Installing DCOracle2 ... for Zope 2.6.1

Mike Garnsey mgarnsey at ideorlando.org
Fri Mar 19 18:14:56 EST 2004

Rivera -

 >Zope Version
 >(Zope 2.6.1 (binary release, python 2.1, win32-x86), python 2.1.3, win32)
 >When I run the install.py script after renaming the DCOracle folder to 
ZOracleDA reports the following error:
 >Installing: binary release for Python 2.2
 >... test loading DCOracle2 ...
 >ERROR: DCOracle2 failed to load

hmmm, it sounds like the install script is getting confused.  Presumably 
the script should be installing the win32-python-2.1-dco2.pyd as dco2.pyd.

 >Where can I found a pre-built binary for Oracle 9i?

I don't think that Oracle8 vs Oracle9 is your problem.  (At least for 
me, the win32-python-2.1-dco2.pyd has worked fine with Oracle9i)

However, if you can migrate to the newest Zope build (using python 2.3.3 
as incorporated in Plone 2.0), I just re-built the dco2.pyd windows 
binary for Oracle9i.  (look at this thread: [Zope-DB] Re: [Zope] 
ZOracleDA: compiling dco2.pyd for python23 on windows)

good luck!

More information about the Zope-DB mailing list