[Zope-DB] Re:Initializing DCOracle2 and connecting to outsidescript

Barry Sperling barry at angleinc.com
Wed Oct 27 14:43:25 EDT 2004

	When I last worked on this on 10/19 there was an exchange of info here 
about getting an Oracle connection from Zope.  Your time is appreciated, 
but I didn't succeed.  Zope runs ( and is accessible from another LANed 
computer ) but won't startup when the directory DCOracle2 ( or the one 
with the name changed to ZOracleDA ) exists in the
  Program Files\Zope-2.7.2-0\lib\python\Products directory, on my 
Windows 2000 machine, with Python 2.3.3 and Oracle 8i.
	I finished up on the project that I was pulled away for, and now would 
like to go back to the problem of accessing an Oracle database through a 
webpage.  The DCOracle2 package was unzipped again and reinstalled and 
the pyd file was downloaded again and saved.  The previous problems 
still exist.  I am not able to start Zope with that directory installed, 
or use "import DCOracle2" in a Python script.
	When "install.py" is double-clicked a command window shows up very 
briefly and then disappears.
	If anyone can suggest something that I likely may be doing wrong, or 
something that I might have left out, it would be great to hear about it.

Jim Abramson wrote:

> You need to move dco.pyd inside the folder (originally) named
> "DCOracle2" _after_ you extract the other distribution files.  It needs
> to be at the top level of the folder structure that's extracted.
> As an aside I'm not sure there's any real reason to rename the folder to
> ZOracleDA, I think it's purely "cosmetic".  But this shoudn't matter
> either way, as long as that folder, renamed or not, contains the
> dco2.pyd file.
> Don't worry about install.py anymore - all that would do is look for a
> binary to give you, which it won't find and you don't need (you have
> dco2.pyd for 2.3 already).
> Jim
>>Jim Abramson wrote:
>>>well, there appears to be some help here:
>>>The thing you need from here is dco2.pyd (pre-built binaries for py 
>>>2.3 don't come with the distribution, which is the reason your 
>>>install.py is complaining).
>>>I -think- you can just unzip the DCOracle2 dist archive into your 
>>>lib/python/Products folder, and put mikey's dco2.pyd into the outer
>>>DCOracle2 folder there (next to  __init__.py, version.py and 
>>>DCOracle2.py), and that should get you up and running after a Zope 
>>>restart.  However, I'm not a licensed DCOracle2 Support 
>>Technician and 
>>>can guarantee nothing...
>>>Good Luck
>>	Ok, I took the dco2.pyd and put it into 
>>lib\Python\Products and there was a __init__.py but not 
>>version.py or DCOracle2.py.
>>	Next the DCOracle2 was unzipped to the Products folder 
>>and, following instructions, the folder was renamed "ZOracleDA".
>>	Then I rebooted and clicked on the install.py.  A 
>>command window opened briefly and then closed with no message.
>>	Trying to start the Zope instance, however, caused the 
>>same error as 
>>before:   Import Error: no module named dco2	which occurred 
>>twice in the 
>>traceback.  Trying to start Zope reported that there was no 
>>connection with port 8080.  When this happened before I 
>>deleted the DCOracle2 files and things booted OK.
>>	What am I not doing/forgetting?
>>	Thanks,
>>		Barry

More information about the Zope-DB mailing list