[Zope-DB] DCOracle2 and x86_64

Maan M. Hamze mmhamze at pleiades.net
Thu Mar 22 14:53:59 EDT 2007

Maceij -
You got the following:
gcc -pthread -shared  ./dco2.o  -L/opt/oracle/client.9/product/lib32/
-lclntsh -Wl,-rpath,/opt/oracle/client.9/product/lib  -o ./dco2.so
BOTH oracle lib directories should be lib32.  In the above, you have one
pointing to lib32 and the other one to lib.  Change the MAKE file to
reflect this.
Also, make sure that you actually have the 32-bit libs in the lib32.
The point is this:  the paths should be to the location of the 32-bit
libs wherever they are, and the paths above should be set to these
32-bit paths.  Also, LD_LIBRARY_PATH should point to the 32-bit lib
Link, and then point your LD_LIBRARY_PATH to the oracle 64-bit lib path.
This has worked with me without fail with DCOracle2 and other programs
too that use oracle libs.  I use Solaris.
Anybody uses DCOracle2 under 64 bit machine?
Any problems with that?
We have some problems under RHEL4 and 64
bit Operton CPU. Under heavy load our Zope
is just restarting. /var/log/messages says:
(...) kernel: python[10526]: segfault at 00000000a0084c10 rip
0000002a959041a0 rsp 0000002a9ff828d8 error 4
We're trying to realize what may cause this. I don't
expect that it is something with Zope, so
maybe DCOracle2? We are using this with Oracle9.
Anybody knows whether DCOracle2 should or shouldn't
work with x86_64 architecture? Any hints how it should be
configured/installed under such architecture?
I've found some messages on mailing list about
changing paths to lib32/ in some DCOracle2 files:
I tried this but I get:
gcc -pthread -shared  ./dco2.o  -L/opt/oracle/client.9/product/lib32/
-lclntsh -Wl,-rpath,/opt/oracle/client.9/product/lib  -o ./dco2.so
/usr/bin/ld: skipping incompatible
/opt/oracle/client.9/product/lib32//libclntsh.so when searching for
/usr/bin/ld: cannot find -lclntsh
collect2: ld returned 1 exit status
make[1]: *** [dco2.so] Error 1
make[1]: Leaving directory
Maciej Wisniowski


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.zope.org/pipermail/zope-db/attachments/20070322/5eef48a5/attachment.htm

More information about the Zope-DB mailing list