[Zope-dev] New beta GenericUserFolder

Ross Boylan ross@sphinx.com
Tue, 23 Nov 1999 09:20:54 -0800


This note is mostly a feature request.  I don't know if these features
would fit in with what you are doing or not, but I thought I'd throw them
out.  Also, I'm hoping someone would explain to me how I might get the
functionality I need, since several weeks of part-time fooling around
haven't gotten me there yet :)  Also, I have a more general question.  I'll
start with that, for those not into UserFolders:

I notice that a lot of products redefine class variables (e.g.,
GenericUserFolder has
    isPrincipiaFolderish=1
    isAUserFolder=1
) which are already in the superclass.  Is this because:
	* it's more readable
	* Python object model forces this
	* Zope forces it by ignoring the superclass chain (while doing .....)?

Now, here are the two User-specific things I've been trying to do:
1) Let new users define themselves on a new user screen (not a Zope
management console).
I've been hung up on the architectural points of where such a screen should
go, how it is to refer to the acl_users folder, and how to set permissions.

2) Have User objects which are subclasses of user, for extra data and
functionality.
I've been trying to avoid modifying the code in AccessControl/ directly,
since that's cheating (and not robust against Zope system changes).

I think if you took the class as a variable, or took a factory object as an
optional argument to your stuff, it would meet 2) without much trouble.

I know many of these questions are elementary.  I have spent a fair amount
of time RTFMing (such as they are), but I'm still getting a feel for the
system, and would welcome some help.

Thanks.