[Zope-dev] ZCatalog reindex_object

Steve Alexander steve@cat-box.net
Sun, 31 Dec 2000 11:36:54 +0000


Chris Withers wrote:

> Michael Bernstein wrote:
> 
>> reindex_object - should be called when an object is edited
> 
> 
> Hmmm... didn't see this method listed in the interfaces wiki. Where did
> you find it?

reindex_object is a method of the mix-in class CatalogAwareness.

   lib/python/Products/ZCatalog/CatalogAwareness.py line 191

     def reindex_object(self):
         """ Suprisingly useful """
         self.unindex_object()
         self.index_object()

> I just inserted a call to catalog_object which did the job but I wonder
> what the difference between index_object abd reindex_object and
> catalog_object is?

I think calling index_object should work, as a well-implemented catalog 
will do the right thing. However, calling reindex_object makes your 
intentions more explicit.

--
Steve Alexander
Software Engineer
Cat-Box limited
http://www.cat-box.net