[Zope-dev] Re: How to publish Zope2 products on PyPI
dieter at handshake.de
Mon Sep 24 14:49:19 EDT 2007
Philipp von Weitershausen wrote at 2007-9-23 19:24 +0200:
>On 23 Sep 2007, at 19:05 , Dieter Maurer wrote:
>> Philipp von Weitershausen wrote at 2007-9-22 19:27 +0200:
>>> Dieter Maurer wrote:
>>> * PyPI doesn't necessarily have to contain eggs. It's primarily a
>>> discovery mechanism for humans. The fact that setuptools can download
>>> packages from it is not as important as the fact that developers can
>>> find packages there.
>> The reason why I had to promiss to make my products available via PyPI
>> was that they can be downloaded from there.
>Right. So then I don't understand why need all that extra machinery
>in Zope and an extra namespace.
Others already have pointed out, that the namespace already exists in
"PyPI": "Products". It was not obvious ;-)
I am fine with this.
"all that extra machinery" means a declaration "additional-product[s]" --
something I have learned meanwhile exists already in Five as
"registerProduct". I explain below why I think "Five" is not the proper
>> Thus, the functionality is there -- just maybe in the wrong place.
>If Five's registerPackage functionality is what you had been
>proposing all along, then I have been misunderstanding you terribly.
>Either way, you don't elaborate on why you think that this is the
>"wrong" place for it. I personally consider registerPackage a
>solutino for integrating new software (Zope 3-style software in
>Python packages) into a legacy discovery mechanism (the automatic
I have already sketched my reason why I deem "Five" the wrong
place to a "registerProduct". I repeat it again:
* Five is the vehicle to make Zope 3 concepts available
in Zope 2.
A product is a Zope 2 concept. Zope 3 does not have it.
Thus why, what has Five to do with Zope 2 products?
* "zope.conf" has already a declaration that controls
which products are used by an instance "products".
When we need another one (I do feel this need),
I would have put it there, in "zope.conf", where
already the other declaration lives -- and not in "Five".
Having one declaration in "zope.conf" and one in "Five"
looks like bad design for me...
More information about the Zope-Dev