[Zope-dev] package dependency refactoring progress report

Martijn Faassen faassen at startifact.com
Sun May 24 13:32:35 EDT 2009

Hi there,

Shane Hathaway wrote:
> Summarizing:
> zope.app.publisher -> zope.view
> zope.app.publication -> zope.publicationregistry
> zope.app.http -> zope.rest

I'm not sure about zope.rest; there's already a z3c.rest which likely 
does something quite different, and I think a "zope.rest" package should 
actually *talk* about REST. What about "zope.httpview" instead?

Another note, I think we should consider splitting off 
zope.app.publisher.xmlrpc, which looks quite independent from the rest, 
into its own package. So:

zope.app.publisher -> zope.view, zope.xmlrpcview

One question is whether zope.httpview and zope.xmlrpcview are really 
similar enough to warrant such a similar naming convention. 
zope.app.publisher.xmlrpc does not only define some XMLRPC-related 
views, it also defines a ZCML directive, which zope.httpview doesn't do. 
I also wonder what should happen with zope.publisher.xmlrpc (which also 
looks quite independent from the rest of the zope.publisher code).



More information about the Zope-Dev mailing list