[Zope-dev] RFC: Site -> Locus
faassen at startifact.com
Thu May 28 08:46:11 EDT 2009
Wichert Akkerman wrote:
> Previously Martijn Faassen wrote:
>> I propose we use the word 'Locus' instead of 'Site'. This word doesn't
>> have a lot of connotations in the web programming world, and people can
>> guess by simply looking at the word it might have something to do with
>> *local* components. It's also short.
> I don't see short as a very important quality here. It is not a name you
> have to type in often, so I would prefer something more descriptive. How
> about "componentroot" or "componentcontainer"..
I do find short an important quality here, because I find myself typing
"getSite()" frequently, and in tests, "setSite" as well. It's also
something one talks about.
A site isn't a container, I'll note. A site is something that has local
components registered but doesn't need to be implemented as a container
More information about the Zope-Dev