[Zope-dev] zope-tests - FAILED: 2, OK: 13

Marius Gedminas marius at gedmin.as
Mon Nov 4 10:26:46 CET 2013

On Mon, Nov 04, 2013 at 01:00:02AM +0100, Zope tests summarizer wrote:
> [1]    FAILED  winbot / z3c.recipe.paster_py_265_32
>        https://mail.zope.org/pipermail/zope-tests/2013-November/079511.html
> [2]    FAILED  winbot / zope.testrunner_py_265_32
>        https://mail.zope.org/pipermail/zope-tests/2013-November/079512.html

Both fail because something prints

    Not SVN Repository

in the middle of doctest output.

It is probably printed by setuptools[1] by code that was added just
over a month ago[2] and *probably* released recently[3].

[1] https://bitbucket.org/pypa/setuptools/src/ca2fc862ded7e3a2c07397f0d7d929a9534493a7/setuptools/svn_utils.py?at=default#cl-247

[2] https://bitbucket.org/pypa/setuptools/commits/cacdb3af1d3d2793e94084e59f0a144c5d2ba36e

[3] *augh* no release dates in https://pypi.python.org/pypi/setuptools#changes
    but I'm guessing "Added support for SVN 1.7" is a clue.

What stumps me is that if we compare the last good build [4] with the
first broken build [5], we see setuptools_ver step claiming 0.9.5,
then we see the bootstrap step claiming 0.6c11, and then we don't see
the buildout step mentioning setuptools at all.  In both builds
(although the broken one includes the "Not SVN Repository" warning in
buildout output).

So how do we get the new setuptools version, and which one do we get?  I
can rdesktop into winbot[6] and peek around the build tree[7] and see
setuptools-1.3-py2.6.egg in parts/buildout/site.py.

[4] http://winbot.zope.org/builders/z3c.recipe.paster_py_265_32/builds/436
[5] http://winbot.zope.org/builders/z3c.recipe.paster_py_265_32/builds/437
[6] Damn buildbot for not letting us browse the workspace through the web.
[7] /c/buildslave/z3c.recipe.paster/build/

Anyway, what next?  Options I can think of:

- modify the two failing projects to install a logging handler in
  setUp() to ignore the log.warn() call in setuptools/svn_utils.py

- file a setuptools bug and ask for that warning to be
  omitted/downgraded, then wait for setuptools 1.3.1.

Marius Gedminas
http://pov.lt/ -- Zope 3/BlueBream consulting and development
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: Digital signature
URL: <http://mail.zope.org/pipermail/zope-dev/attachments/20131104/6069c889/attachment.sig>

More information about the Zope-Dev mailing list