[Zope-dev] zope-tests - FAILED: 119, OK: 8

Maurits van Rees m.van.rees at zestsoftware.nl
Wed Dec 17 21:15:45 CET 2014

Marius Gedminas schreef op 17-12-14 10:14:
> On Wed, Dec 17, 2014 at 01:00:03AM +0100, Zope tests summarizer wrote:
>> [1]    Still Failing - zopetoolkit_trunk - Build # 855
> Last build of zopetoolkit_trunk was successful, woohoo!
> It's pinning buildout to 2.2.4 and setuptools to 7.0, so maybe the
> woohoo was a bit premature.
>> [2]    winbot / BTrees_py_265_32
> ...
>> [119]  FAILED  winbot / zope.traversing_py_265_32
>>         https://mail.zope.org/pipermail/zope-tests/2014-December/085611.html
> The variety of errors has decreased somewhat.  Most of the builds
> fail with
>    Error: Couldn't find a distribution for 'zc.recipe.egg<2dev,==1.3.0,>1.3.0'.

setuptools version 8 is used, which complains about this stuff.  Initial 
solution would be to make sure setuptools 7.0 or earlier is used.

Running bootstrap.py in this buildout (zope.traversing) will give you a 
bin/buildout with zc.buildout 1.7.1 and the latest setuptools version, 
which currently is 8.0.4.  I suppose this is true for most or all ztk 

Some solutions are thinkable:

- Pin setuptools to 7.0 or earlier.  This gives bin/buildout a chance to 
downgrade from the 8.0.4 that bootstrap is currently giving.  I have 
done that on zope.traversing now.  Let's see.

- Call 'python bootstrap.py 
--download-base=http://pypi.zestsoftware.nl/public/oldsetuptools/' or 
some other web page that has links to at most setuptools 7.0 and 
possibly zc.buildout.  According to the help text of bootstrap.py this 
should help, but I tried it and it did not work.  Maybe it needs to be 
behind https.

- Call 'python2.7 bootstrap.py 
--setup-source=https://bitbucket.org/pypa/setuptools/raw/7.0/ez_setup.py' so 
bootstrap calls an ez_setup.py that defaults to setuptools 7.0.  Maybe 
this works on the buildbots, but locally it failed for me:

   The required version of setuptools (>=7.0) is not available,
   and can't be installed while this script is running. Please
   install a more recent version first, using
   'easy_install -U setuptools'.

   (Currently using setuptools 0.9.8 

- Use https://bootstrap.pypa.io/bootstrap-buildout.py and call it with 
'--version=1.7.1 --setuptools-version=7.0' (or whatever version you 
prefer).  This may be the best solution.

> Several fail with
>    Error: There is a version conflict.
>    We already have: zc.recipe.egg 1.3.2
> which seems like it could be the same thing?  but maybe different
> buildout version or something?
> Then we have a couple of
>    The constraint, 4.0.0a3, is not consistent with the requirement, 'zope.security>4.0.0a2'.
> and one
>    Error: There is a version conflict.
>    We already have: zc.buildout 1.7.1
> and one
>    Error: Couldn't find a distribution for 'zope.app.wsgi<3.11,<4.0dev,>=3.12'.

Presumably the errors will disappear when using setuptools 7.0 or 
earlier.  Maybe some will disappear with future 8.x versions.  This last 
one definitely needs an actual fix at some point though.  Some package 
has '<3.11,>=3.12' as version restriction, which is apparently meant to 
blacklist the 3.11 version.  This should become '!=3.11'.  See 

Maurits van Rees: http://maurits.vanrees.org/
Zest Software: http://zestsoftware.nl

More information about the Zope-Dev mailing list