[ZWeb] invalid token error

Christian Theune ct@gocept.com
Wed, 13 Mar 2002 08:24:50 +0100


This looks like you are running the statements from inside python? ( the >>>
look like the python prompt) Thats not the way it was intended to be used.

python ./load_site.py (see the / instead of \ - we are on unix here, ay?)

and use the full location if -D wants an URL it needs to be valid too:

	python ./load_site.py -u user:password -D http://localhost:8080/test/ /tests/

* Manish Sharma <manish_ssharma@yahoo.com> [020313 07:40]:
> I want to upload some files in zope using load_site.py While running the
> command in python i m getting the error like Syntex error : invalid token
> the command statement is
> >>> python .\load_site.py -u manish:manishkumar -D http:localhost:8080/test/
> >>> /tests/
> here test is a folder created in zope manager and tests is come with
> Load_site kit havinf three .htm files.
> i tried wxLoadSite.py through python 
> >>> python .\wxLoadSite.py
> it also giving the same error of invalid token please tell me the
> solution......  manish

Yes, up to your second example, it looks like you try to start python scripts
from within the interpreter. Try here also (on your shell) "python



Christian Theune - ct@gocept.com
gocept gmbh & co.kg - schalaunische strasse 6 - 06366 koethen/anhalt
tel.+49 3496 3099112 - fax.+49 3496 3099118 mob. - 0178 48 33 981

reduce(lambda x,y:x+y,[chr(ord(x)^42) for x in 'zS^BED\nX_FOY\x0b'])