[Zope] Need help with ZJetDA, Winnt4 and Zope 2.2.1

Farrell, Troy troy.farrell@wilcom.com
Fri, 8 Sep 2000 11:44:26 -0500

I appreciate your response.  I had copied the data.fs over to the server
with no success.  I have the (buzzword alert)"web app" up and running on
ZODBCDA.  I still haven't solved the ZJetDA problem, but with ODBC, I may
well ignore it.  I wonder if iODBC or unixODBC is able to connect to access.
I will let you know if I figure it out.

My Zope versions are the same and I have the same products on each.  I think
I must have screwed up my permissions somewhere, but I think it might be on
the NT side instead of Zope.  I say this because the superuser cannot test
the adapter successfully with permissions wide open with and without

More to come.


-----Original Message-----
From: Rik Hoekstra [mailto:rik.hoekstra@inghist.nl]
Sent: Friday, September 08, 2000 4:33 AM
To: Farrell, Troy
Cc: 'zope@zope.org'
Subject: Re: [Zope] Need help with ZJetDA, Winnt4 and Zope 2.2.1

"Farrell, Troy" wrote:
> As you have no doubt heard my cries for help, I figure that very few are
> running NT4.  

More than would admit it, probably. Perhaps no one knows the answer to
what seems to be a rather specific situation. For one, I have the
impression most people use zodbc connections to access database then use
the zjetadapter (so do I, so chances are I might be just blabbering).

> I am having a permissions difficultie with ZJetDA trying to
> modify data in an Access97 database.  On my server, the DA is able to
> * FROM tablename with no problem, but when it comes to INSERT INTO
> VALUES (...) or UPDATE, I get a Query Error with a value of INVALID
> OPERATION.  I mirror (It is identical, i checked 5+ times) all the objects
> on my NT4 laptop and it works ok.  The databases are Identical, I copied
> working one to the non-working server and still no go.  The traceback is
> follows:

hm one stupid question: isn't by accident the working one read-only by
accident (this happened to me more than once and it _will_ happen if the
access file is not copied properly. Who knows what copying properly is -
please speak up). 

> __call__
>     (Object:
>   File C:\PROGRA~1\JESTER\lib\python\Products\ZJetDA\db.py, line 130, in
> query
> Query Error: (see above)

you could try this with the zodbc adapter. Please make sure you odbc
connection is made under the system account though.

> Rant:
> I've been working on this for days.  I don't seem to understand the
> model since I didn't have any problems before 2.2.x.  If I cannot get this
> resolved, I'll move back to the 2.1.x series.  I really want this to work
> it is my companie's introduction to open source software.  Have a :) day.

hm is the Zope version the same on your laptop and your server then? If
so, then the security thing should be the same on both,  right? If not -
then how can you say all objects are the same? Did you copy you data.fs
database from one machine to the other?

success, let us know how it goes



Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )