[Zope] Copy/Paste DTML method raises exception "does not support this operation"

Brad Clements bkc@murkworks.com
Mon, 11 Sep 2000 11:06:05 -0400

I think my Zodb is messed up, I'm running Zope 2.2.1 (binary release, python 1.5.2, win32-x86) 

I copied a DTML Method, and tried to paste it into the same folder. I get 
this exception:

The object ReportBanner does not support this operation 

Traceback (innermost last):
  File E:\Zope\lib\python\ZPublisher\Publish.py, line 222, in publish_module
  File E:\Zope\lib\python\ZPublisher\Publish.py, line 187, in publish
  File E:\Zope\lib\python\Zope\__init__.py, line 221, in zpublisher_exception_hook
    (Object: Traversable)
  File E:\Zope\lib\python\ZPublisher\Publish.py, line 171, in publish
  File e:\Zope\lib\python\ZPublisher\mapply.py, line 160, in mapply
    (Object: manage_pasteObjects)
  File E:\Zope\lib\python\ZPublisher\Publish.py, line 112, in call_object
    (Object: manage_pasteObjects)
  File E:\Zope\lib\python\OFS\CopySupport.py, line 203, in manage_pasteObjects
    (Object: Traversable)
  File E:\Zope\lib\python\OFS\CopySupport.py, line 406, in _verifyObjectPaste
    (Object: Traversable)
Copy Error: (see above)

The DTML Method was un-owned, I took ownership and retried 
copy/paste, get the same error again.

I can't paste it into a different folder either.

How can I figure out what's happening? I'm worried that my ZODB has 
become corrupted. I'm logged in as manager.

Brad Clements,                bkc@murkworks.com   (315)268-1000
http://www.murkworks.com                          (315)268-9812 Fax
netmeeting: ils://ils.murkworks.com               AOL-IM: BKClements