[Zope] Using GUF (generic user folder) under 2.2.x?

César A. K. Grossmann ckant@fazenda.gov.br
Tue, 19 Sep 2000 11:12:11 -0300

Danny William Adair wrote:
> I've experienced the same problem with GUF (which is why I am desperately
> waiting for the LoginManager HOWTO). Everything looks fine first, but the
> login screen will keep reappearing. Which part of the walkthrough could be
> out of date, the password? ;-)

I experienced some weirdness with GUF in the Zope 2.1.6. I write the
correct login and password, and get the same login screen after pressing
the button. Then I:

1. revised all the Proxy settings for the methods in the acl folder, and
put everything as Manager (in the proxy). Same result;

2. revised all the security properties. The GUFTest folder doesn't
inherit any security property, and Anonymous can oly "access content
information", and "can login and logout". Same results.

The more weird thing I do: after getting the second login screen, I
pressed the "Reload" button (Netscape 4.75 in a Linux box) and get the
index_html page! So I changed the docLogin method and put the line
bellow in the HEADER part of the HTML:

<meta http-equiv="Pragma" content="no-cache">

Then, after the login, the index_html page appears without the need of a
reload in a Linux Netscape. In the Windows version of the Netscape it
doesn't works...

I don't have tried GUF with a 2.2.x Zope version (I'm still figthing to
put the Zope/PostgreSQL connection to work).

Sorry my bad english, I'm brazilian...

 | César A. K. Grossmann           | Capacitação Solidária           |
 | ckant@fazenda.gov.br            | http://www.uol.com.br/umminuto/ |
 | http://members.xoom.com/ckant/  | Clique e doe - é de graça       |
If I had any humility I would be perfect.
		-- Ted Turner