[Zope] RE: Stability problems using ZOracleDA

Andy Pahne ap@big1.de
Mon, 25 Sep 2000 20:49:05 +0200


we were suffering from the same problem, but now it works.

when you use ZOracleDA, be sure not to use DCOracle, which ships with it.
There's a newer version on the Zope site. Use the new one instead and
everything will be fine.

Our systems admin told me that he also modified either ZOracleDA or
DCOracle, I'm not sure, butr I'm gonna ask him to post here...

Andy P.

>Subject: [Zope] Stability problems using ZOracleDA
>Recently I have been having some severe stability problems using
>zope and oracle together. Zope has been segfaulting on a regular
>basis, usually every 10-15 mintues. When I looked into it a while
>back I came to the conclusion it was a problem with the linux version
>of oracle (an incompatibility with glibc 2.1), but I have tested
>it on solaris now and I am having the same problems.
>  Redhat 6.2 (intel)
>  Oracle 8.1.6
>  Python 1.5.2 (compiled from sources --with-threads)
>  Zope 2.2.2 (compiled from sources)
>  ZOracleDA 2.2.0b1 (compiled from sources, also tried 2.1.0)