[Zope] python: can't open file 'zpasswd.py'

Daniel Muller dmuller@angel.net
Thu, 17 May 2001 13:25:09 -0400

I've just completed an rpm install of zope on a linux box and I'm
not able to log into the management screen.

Zope is running.  I can see it fine at:

I next tried to log onto the management screen:
and was prompted for a username and password

I entered
u: superuser

and receiver the "unauthorized user " message.

Next I logged onto my server trying to run zpasswd.py

I tried various ways to run this script including:
/usr/bin/python1.5 zpasswd.py /var/zope/access

Every time I get the following message:
python: can't open file 'zpasswd.py'

[root@puccini bin]# ls -l zpasswd
-rwxr-xr-x    1 root     root         9546 May  8 16:00 zpasswd

[root@puccini zope]# ls -l access
-rw-r-----    1 root     zope           65 May 17 10:16 access

I've searched this mailing list for answers but I'm still stumped.

1. Why can't run zpasswd.py

2. Can I edit the access file manually?
(Here is what the access file looks like: