[Zope] ZClass 'UNSLICEABLE OBJECT' Error Value

Joachim Werner joe@iuveno-net.de
Tue, 29 May 2001 01:06:06 +0200

Haven't I answered to that already? ;-)

> I am trying to create specialized document classes that have unique
> propertysheets, methods,  are CatalogAware and renderable via <dtml-var
> ...>.  I have been able to successfully build a structured-text document
> class that meets these criteria, however, I am unable to build an HTML
> document class.  If I try to use OFS:DTMLDocument or OFS:DTMLMethod as my
> base class,  the ZInstance attempt throws a TypeError with a value of
> 'unsliceable object'.  I have tried many variations on this theme and none
> were successful.  I thought I had a handle on ZClasses but I am obviously
> missing something major.  Note: not that this has anything to do with the
> above, but I can subclass OFS:File and OFS:Image with no problem.  I am
> using Zope version 2.3.1 on a Win2K platform.
> Any hints, insight, direction, further-reading links would be greatly
> appreciated.

I guess it really just is that bug that crept in after 2.3.0 (and which
should be fixed in 2.3.2) ...
If it still doesn't work with 2.3.2, please tell me