[Zope] ZClass 'UNSLICEABLE OBJECT' Error Value

Eric Roby vekn@msn.com
Mon, 28 May 2001 19:58:48 -0500

Sorry Joachim,

I misunderstood your previous response on the zope-dev listing.  I thought
it might be something I was misunderstanding about ZClasses.
I will load 2.3.2 and see if I still have that problem.  Thanks for your


> Haven't I answered to that already? ;-)
> > I am trying to create specialized document classes that have unique
> > propertysheets, methods,  are CatalogAware and renderable via <dtml-var
> > ...>.  I have been able to successfully build a structured-text document
> > class that meets these criteria, however, I am unable to build an HTML
> > document class.  If I try to use OFS:DTMLDocument or OFS:DTMLMethod as
> > base class,  the ZInstance attempt throws a TypeError with a value of
> > 'unsliceable object'.  I have tried many variations on this theme and
> > were successful.  I thought I had a handle on ZClasses but I am
> > missing something major.  Note: not that this has anything to do with
> > above, but I can subclass OFS:File and OFS:Image with no problem.  I am
> > using Zope version 2.3.1 on a Win2K platform.
> >
> > Any hints, insight, direction, further-reading links would be greatly
> > appreciated.
> I guess it really just is that bug that crept in after 2.3.0 (and which
> should be fixed in 2.3.2) ...
> If it still doesn't work with 2.3.2, please tell me
> Joachim