[Zope] Problems when creating mysqlUserFolder using cookie authentication

Heimo Laukkanen huima@fountainpark.org
Fri, 12 Oct 2001 09:07:06 +0300

I am having problems with mysqlUserFolder - when trying to use
cookie-based authentication. EVerything is sweet with basic
http-authentication, but when I try to switch on the cookie based auth -
I run into probelms. If I have created the folder first with http-login
and switch from properties to cookie-based, I just get not authorised
error, when I try to access the folder.

If I try to create the mysqlUserFolder from start with the cookie based
auth. I get the following error.

You are not authorized to access <em>aq_parent</em>.
Traceback (innermost last):
  File /usr/lib/python1.5/site-packages/ZPublisher/Publish.py, line 223,
in publish_module
  File /usr/lib/python1.5/site-packages/ZPublisher/Publish.py, line 187,
in publish
  File /usr/lib/python1.5/site-packages/ZPublisher/Publish.py, line 162,
in publish
  File /usr/lib/python1.5/site-packages/ZPublisher/BaseRequest.py, line
446, in traverse
  File /var/zope/Products/mysqlUserFolder/mysqlUserFolder.py, line 566,
in validate
    (Object: RoleManager)
  File /usr/share/zope/lib/python/OFS/DTMLDocument.py, line 189, in
    (Object: docLogin)
  File /usr/lib/python1.5/site-packages/DocumentTemplate/DT_String.py,
line 538, in __call__
    (Object: docLogin)
  File /usr/lib/python1.5/site-packages/DocumentTemplate/DT_Util.py,
line 328, in eval
    (Object: REQUEST.set ('ppath',  aq_parent.absolute_url ()))
    (Info: aq_parent)
  File /usr/share/zope/lib/python/OFS/DTMLMethod.py, line 261, in
    (Object: docLogin)
  File /usr/share/zope/lib/python/AccessControl/SecurityManager.py, line
144, in validate
  File /usr/share/zope/lib/python/AccessControl/ZopeSecurityPolicy.py,
line 225, in validate
Unauthorized: (see above)


Any ideas where to look into?

Version of mysqlUserFolder is 0.6 - I tried also with 0.6.1 with no
better success.