[Zope] Input/output error

a32955@pop-server.nc.rr.com a32955@pop-server.nc.rr.com
Tue, 16 Oct 2001 08:11:37 -0400

I had a similar problem when I exported a .zexp file from Zope 2.3.0 
(Linux) and tried to import it into Zope 2.4.1 (Linux).  I could not import 
the file at all, unless I selected 'Retain existing ownership information' 
on the Import form (instead of 'Take ownership of imported objects').  But 
after importing this way, like you I would get the same IOError when I 
clicked on one of the imported folders.  So the imported objects were unusable.

I posted the problem on the zope-dev list but got no response, so I assumed 
I was the only one who had experienced this.

My problem eventually went away (by itself?), but I can't say exactly 
why.  I deleted the imported folders, restarted Zope, and then imported 
again and things seemed to work OK.  But I have not been able to replicate 
the error and don't know if restarting Zope solved the problem or whether 
it was just a coincidence.  Very strange.


At 11:10 AM 10/16/01 +0200, you wrote:
>  Dear All,
>  I have imported the .zexp file from my NT machine to the Linux .
>  But as i try to click on the imported folder then I get the following
>  error.
>  Any Ideas why?
>  Error Type: IOError
>  Error Value: [Errno 5] Input/output error