[Zope] ImportError on Zope startup

Timothy Wilson wilson@visi.com
Sat, 20 Oct 2001 14:18:20 -0500 (CDT)

Hi everyone,

I'm trying to get Zope 2.4.1 running with ActivePython 2.1.1. I compiled
Zope with no trouble and was able to run it initially. The problem came when
I tried to set it up with an INSTANCE_HOME. (Which is how 2.3.3 was running
on this box.) I'm using Linux, BTW.

Here's the start script:

beethoven:/var/zope# cat start
#! /bin/sh
reldir=`dirname $0`
INSTANCE_HOME=`cd $reldir; pwd`
exec /usr/local/bin/python2.1 \
     $PYTHONHOME/z2.py \
     -X -w 8080 "$@"

When I try to run the start script I get:

beethoven:/var/zope# ./start
'import site' failed; use -v for traceback
Traceback (most recent call last):
  File "/var/zope_soft/z2.py", line 296, in ?
    import os, sys, getopt, string
ImportError: No module named os

It's a little strange that 2.4.1 would run OK without the INSTANCE_HOME
start script, the INSTANCE_HOME start script worked fine w/ Zope 2.3.3 (and
Python 1.5.2), and my ActivePython (/usr/local/bin/python2.1) is certainly
capable of importing 'os'.

Any ideas?


Tim Wilson      |   Visit Sibley online:   | Check out:
Henry Sibley HS |  http://www.isd197.org   | http://www.zope.com
W. St. Paul, MN |                          | http://slashdot.org
wilson@visi.com |  <dtml-var pithy_quote>  | http://linux.com