[Zope] (no subject)

McDonnell, Larry lmcdonnell@protonenergy.com
Fri, 12 Jul 2002 13:53:50 -0400


I have a strange problem that I thought someone out there knows the answer.
In my pilot, using Zope technology, I have been able to create a simple
search engine for our company. Since I have no money (yet) for this project.
I used MS Access as my DB. Mainly so the users can use the reporting tools.
Each search was place in it's own table, to make thing easier for me.
Everyone like what they saw but it also got them thinking and the decision
was made to combine the tables into one. 

Now I was dealing with test data and I would take the excel spreadsheets and
import them into Access. This worked, the users could see the data from one
interface. Again, I was asked to add our New Part Numbering data into this
one table. Again the spreadsheet was imported and I have a total of 3000
records (stop laughing). My problem is Zope can not see the part number
information. Using Z SQL Method, I can view all the old data but no part
number information. I can see everything in Access but not through Zope.

To make things worst for me, before this last decision was made, I had
written an Zope interface to the Part Numbering system. At the time I had
1500 part numbers that was imported (excel) into Access and I was able to
view the information as well as add new records. I wrote this because I
found duplicate part numbers under their filtered spreadsheet method. I have
tried several different ways to import the information but I still hit the
same brick wall, Any thoughts??

Larry McDonnell

Proton Energy Systems
50 Inwood Rd.
Rocky Hill, CT 06067
(860) 571-6533 ext. 531