[Zope] Heeeeeeeeeeeeelp (login problem)

Charlie Reiman creiman@kefta.com
Thu, 18 Jul 2002 10:34:16 -0700

More suggestions & questions:

* Do you have some sort of proxy system installed?
* can you telnet to zope? "telnet 8080"
* what's the output from "netstat -n -a"?
* what's the output from "ipconfig /all"?
* can you ping yourself? "ping"
* is the TCP stack installed?
* is the computer plugged in and turned on? :-)

Now that I wrote those out, you probably should try them in reverse order...

It sounds like you have basic networking issues. Unfortunately, you've got
them under '98 which means most of us will wince and tell you to upgrade to
NT/2000/XP/Linux, which I know you probably don't want to hear. To be
honest, I'm not even sure if netstat and ipconfig are available under '98.

I wish I could be more help. Of course, I wish Microsoft never reased '98,

-----Original Message-----
From: zope-admin@zope.org [mailto:zope-admin@zope.org]On Behalf Of Breuer,
Sent: Thursday, July 18, 2002 1:10 AM
To: zope@zope.org
Cc: tpassin@mitretek.org; renfro@tntech.edu; plasser@hexagon.at;
Subject: RE: [Zope] Heeeeeeeeeeeeelp (login problem)

Hi again,

First of all I'd like to thank those who've been trying to help me.
Unfortunately it hasn't been successfull so far. So, here's an update on the
current status. Maybe you'll find more info to help me out.   :-)

When I wrote my first mail (see below) this was how START.BAT looked like:
Trying offline with no NIC installed, see attachment: no_nic_offline.txt
Trying online with no NIC installed, see attachtment: no_nic_online.txt
And my hosts.sam file looked like this (still does), see attachment:

After your tips I tried several but --as you already understood-- without
success. So, I got myself a NIC and installed it. It was recognized by Win98
and drivers were installed. Now I tried to login offline again but unluckily
again without success. This is how START.BAT looked like:

Other settings etc.:
Windows 98 SE
Computername: POPEYE
Browser: Ms Internet Explorer 4.5
Zope version: 2.5.1
Zope superuser: StJohnHospital
NB: Everytime I tried to login, I used all of the following addresses:

Hopefully this leads to solving my problem!

Many thanks!

Yvon Breuer

-----Original Message-----
From: Breuer, Yvon
Sent: Dienstag, 16. Juli 2002 10:30
To: zope@zope.org
Subject: [Zope] Heeeeeeeeeeeeelp (login problem)

Hi Zope-wizards,

As you can see in my subject: I'm getting quite frustrated by some stupid
error when I'm trying to login to my Zope server. (Yep, I'm a newbie...)

I'm going to create a website to gather funds for a hospital in Ghana (St.
John of God Hospital in Duayaw Nkwanta).
To get an idea about the situation:
http://www.zwo.nhl.nl/hbov/buitenlandstage/ghana.html (Dutch & English).

I want to do this with Zope & Python. I want people to be able to do online
donations, retrieve information about the project, maybe send a mailinglist
to keep them up to date and there are many more plans. So: I've got a lot to

Learn & develop @ work & @ home
In order to learn as quickly as possible I tried to install Zope at work and
at home (of course during my break ;-) ). At work (Win2000 Prof.),
everything functions OK. I've done the tutorial and I'm now working myself
through the ZopeBook. So far so good, but...

My problem
At home I've installed Zope (2.5.1) on my computer (Win98). No errors
occured during installation. So, just like at work I tried to login to Zope
for the first time, but...
When I start the START.BAT, my computer starts a dial-in to my
internetprovider! It seems this occurs when START.BAT is trying to retrieve
my hostname. When START.BAT is finished, I type in... (START.BAT comes up with as localhost
and 8080 as port)
http://popeye:8080/manage or http://popeye:8021/manage (popeye is the
computername in my Win98 network-settings and START.BAT comes up with popeye
as localhost for port 8021)
http://localhost:8080/manage (should always work, right? Not!)
http://stjohnhospital:8080/manage (stjohnhospital is the superuser I
installed Zope with)
... but none of them works!!!
All that happens is that my browser (MsIE) when I'm offline shows me that
the page cannot be found and when I'm online it shows me either "server
error" or "page not found".   >:-((

NB: It doesn't matter wether I login to my internprovider or not. I'm quite
sure it's nonesense to be online in order to login to a local Zope-server,
but hey, I've tried everything possible (as far as I know). I also tried to
un- and reinstall Zope, but that didn't work either.   :-(

So please, help me out here!!! (In a short while I've got some days off and
I want to do some work for the website at home.) Not only me, but also the
people we're trying to help will be very gratefull!   ;-))

Best regards,

Yvon Breuer