[Zope] Stupid newbie question

Dieter Maurer dieter@handshake.de
Mon, 10 Jun 2002 20:42:07 +0200

David Archer writes:
 > I was trying to install the etcUserFolder object on my Zope server so I
 > downloaded the tarball and it extracted into the correct directory
 > (lib/python/Products/etcUserFolder). I had to muck about with some sym-links
 > to libcrypt on my box (It's running FreeBSD 4.4) and after a few restarts,
 > it saw it as a successfully installed product. I then proceeded to delete my
 > root acl_users folder (it only had one entry in it anyway) and add a new
 > etcUserFolder object. Now I can't login at all to any of the manage screens
 > to fix it.
 > I tried the zpasswd.py script to generate an access ... file
That should have worked...

But maybe, "etcUserFolder" is broken and does not check against the
emergency user (defined in "access").

I have a rude method for you:

  Back up you "Data.fs".

  Use "fsrecover" in "lib/python/ZODB" to analyse the latest
  trunsactions in your "Data.fs" and cut of several transactions
  (up to the deletion of you "acl_users"). You do this with
  "ftruncate" (there is a HowTo on zope.org, search for "corrupt").

  Restart Zope