[Zope] External Editor on Win32 -- downloading files with .html extension

Grégoire Weber gregoire.weber@switzerland.org
Tue, 18 Jun 2002 12:34:42 +0200

Hy Casey,
hi Juergen,

My conclusion after hours of testing: It seems that integration of NS and 
Mozilla into Win2k is not really good or Win2k has problems.

>I'm not sure you need the "%1" at the end for Netscape or Mozilla.

I tried it with and without in NS and Moz and Win2k-Config. Without 

> How did you setup the application/x-zope-edit MIME type in win2k?

Action: Open
  D:\prog\Python22x\pythonw.exe D:\prog\ZopeEdit\zopeedit.py "%1"

Should be correct. Tried the same also without "%1".

NS 4.79 works (+/-)

It seems that the system file extension config and the config in NS and 
the config in Mozilla influence each other in a not so transparent 
manner :-(.

In NS 4.79 I'am able now to open all types of objects independantly of the 

  In NS I see two Helper Applications configured. One coming from the system
  and one obviously coming from Mozilla (Now 1.0).

  Name: Zope External Editor (from system, not seen by Mozilla)
  Extension: zope
  Mime: --
  App: d:\prog\Python22x\pythonw.exe d:\prog\ZopeEdit\zopeedit.py "%1"

  Name: Zoepedit File (from Mozilla, not seen by system)
  Extension: --
  Mime: application/x-zope-edit
  App: d:\prog\Python22x\pythonw.exe d:\prog\ZopeEdit\zopeedit.py 

Normaly it is not possible to configure a Helper App without extension
(System and NS 4.79). In Mozilla you can specify the extension but you 
don't have to.

Mozilla 1.0

Mozilla saves the file into the temp directory but zopeedit.py seems 
not to be started. I even see a short flickering of the download window.

If I start zopeedit.py manualy with the saved file the editor gets 

Duncan: If you like me doing some tests file me your instructions or
        code to make the tests.

Greetings, Greg
Grégoire Weber