[Zope] Problem with ZServer

Quentin Smith quentins@comclub.dyndns.org
Tue, 18 Jun 2002 16:01:16 -0400

Hablo en ingl=E9s para las otras personas aqu=ED.

On Tuesday, June 18, 2002, at 04:02  PM, Antonio Carrasco wrote:

> I=B4m having problems with zope 2.5.1 on W98 when crashes, the light =
> off,
> or not correctly shutdown.
> After that, I start the zserver but when I try to log in, the server=20=

> crashes
> because of an error in logger.py in line 65, in maybe_flush, bad file
> descriptor. I lose my work and have to reinstall Zope.
> I tried to make something, removing temp and index datafs, z2.log, but=20=

> only
> breach to log in in the server, but if i try adding or modifing=20
> objects, i
> recieve the same error.
Try copying the Data.fs file out of your zope dir, reinstalling zope,=20
and copying Data.fs back. If that works, then something else must be=20
getting changed. If that doesn't work, try running fsrecover.py on your=20=

Data.fs. I believe there are many docs on zope.org on how to do this.
> =BFWhats the problem?.=BFBug?. =BFAm i doing something wrong?

PS. Estudio espa=F1ol en mi colegio para dos a=F1os. No s=E9 mucho.