[Zope] External script question

Kevin Carlson khcarlso@bellsouth.net
Mon, 24 Jun 2002 14:18:36 -0400


It is a rather long involved script, but here is the piece that is failing.
I am trying to integrate with mailman and create a new list by using the
following script:

   nlcommand = "/home/mailman/bin/newlist -q test test@test.org test"

   if(os.system(nlCommand)) :
      retval = "newlist command failed."
      return retval

When I run this script fragment from the shell logged in as user "zope", the
newlist command succeeds.  However, when I run it from the Test tab as
mentioned, it fails.  If I comment out these few lines, the rest of the
script runs as expected.


-----Original Message-----
From: zope-admin@zope.org [mailto:zope-admin@zope.org]On Behalf Of
Jerome Alet
Sent: Monday, June 24, 2002 2:14 PM
To: Kevin Carlson
Cc: zope@zope.org
Subject: Re: [Zope] External script question

On Mon, Jun 24, 2002 at 01:51:57PM -0400, Kevin Carlson wrote:
> I have an external script that runs fine when I invoke it from the shell
> user "zope".  However, when I try and run this script from the "Test" tab
> within the ZMI, it fails.  Can anyone point me in the direction of a
> solution for this?

could you show us the script so we could look at it and maybe be able to
answer ?

Jerome Alet

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists -
 http://lists.zope.org/mailman/listinfo/zope-dev )