[Zope] Zope Newbie having performance problems with v 2.6.1 needs a little advice...

Dominic Caffey dcaffey_fl@yahoo.com
Sat, 7 Jun 2003 17:08:48 -0700 (PDT)

Dear Zope Community,

     A little advice on the following problem
would be appreciated:  I recently downloaded v
2.6.1 as Zope-2.6.1-linux2-x86.tgz from
www.zope.org  and installed in in /usr/local/Zope
on RedHat 9.0 running on a Pentium Pro 180 MHz
w/128Mb ram.  RHL-9 is running fine but I can't
say the same for Zope.  The static index page
from the webserver comes up fine and the ftp
server works like a champ but when I try to get
into the management console after successfully
authenticating the console never fully comes up
or  comes up but with a lot of broken images and
I can't get to anywhere below the root level
and/or the webserver never completes the request
to the browser I'm hitting the server from.  I've
tried this both on the same machine that Zope is
running on and from other machines in my LAN and
I always get the same behavior.  I've checked the
log files: /usr/local/Zope/zope_event_log.log and
/usr/local/Zope/var/Z2.log for complaints from
Zope but there are none; the logs indicate that
Zope is happy but it's not behaving as if it is. 
I tried adding the "-t" and "-n" flags to the
start script to get Zope to demand more resources
from the system but still no change.  Here's what
the line from the script currently looks like: 
"exec /usr/local/Zope/bin/python $cwd/z2.py -u
zope -w -f -t 16 -i 30".  Running "top"
on the Zope host while the request is trying to
complete shows that the cpu is 94% idle.  I'm a
little low on disk right now per "df -k" output
[root@den Zope]# df -k
Filesystem           1K-blocks      Used
Available Use% Mounted on
/dev/hda3              2793952   2426412   
225616  92% /
/dev/hda2                97602      9174    
83388  10% /boot
none                     63028         0    
63028   0% /dev/shm

but I kind of doubt this is my problem because
the rest of the system is running so well.  I've
also looked in /var/log/messages and have not
found any problems.  /usr/local/Zope/var is also
owned by root and is wide open per: drwxrwxrwt   
2 root     root         4096 Jun  7 10:31 var.

I also installed Zope 2.5.? on a 400MHz Celeron
w/64Mb running Debian Woody Linux that I've kept
up to date via network apt-get.  Zope on this box
runs like a champ.  Deb-Conf did the whole setup;
I never had to do anything.

I'm inclined to believe that I'm dealing with
some sort of a tuning issue but I am a Zope
"newbie" and am therefore appealing to those more
knowledgeable than myself.  I've been trying to
use the "Zope Bible" by Bernstein & Robertson for
guidance and I've sifted thru the Zope archives
but haven't been able to find anything which
addresses my issues.  Any help/guidance on the
problems mentioned above would be greatly



| Dominic Caffey
| Email:  dcaffey_fl@yahoo.com

Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).