[Zope] python versions and zope
Fri, 27 Jun 2003 12:20:44 -0400
On Thu, Jun 26, 2003 at 08:36:36PM -0700, Terry Hancock wrote:
> On Thursday 26 June 2003 04:18 pm, Dieter Maurer wrote:
> > Dennis Allison wrote at 2003-6-25 09:31 -0700:
> > > Unless I am mistaken, Zope 2.5.1, 2.6.0, 2.6.1 all *require* Python 2.1.3
> > > and will not work with Python 2.2 and later.
> > >
> > > Do we have a problem?
> > No, because
> > * Python 2.1.3 runs very reliably. We do not need maintenance for it.
> > * Zope 2.6 does run with Python 2.x (for "x >= 2")
> Really? Is that official? Because actually, there's a lot of 3rd party
> modules that require 2.2+ (the first that comes to mind is the "constraints"
> module), that I would like to start using. So being forced to stick with
> 2.1 has been a bit annoying (have to maintain two versions of Python,
> can't integrate some packages with Zope, etc).
> If it works, thanks for the info. I'll definitely try it out.
ONe other snag: python >= 2.2 adds docstrings to many built-in
types that did not previously have them. This exposes a lot of
new stuff via the web which could be a security risk.
IIRC this is addressed in the 2.6 CVS branch, but it's not in the
released 2.6.0 or 2.6.1.
> I assume it's a no-brainer that Zope3 will work with later Python versions,
> of course.
currently zope x3 requires python >= 2.2.3.
Look! Up in the sky! It's ALMIGHTY HAMMERLIKE ROBOT INDUSTRIALIST!
(random hero from isometric.spaceninja.com)