[Zope] VideoCapture module fails under Zope on Win32

Tim tim@xxvii.net
Mon, 3 Mar 2003 04:23:23 -0500

Dylan wrote on Sunday, March 2, 2003, 8:36:03 PM:
> Ugh.  Line 49 calls a method in a pyd file.  Tough to know why the filter
> graph creation failed without seeing it.

Been there, done that too. (-: The exception is actually coming from
the call in the c++ code to open the device. The call does return a
code of some sort; but i have no idea what that code is. The module
author simply checks for non-true (or non-false, i can't remember),
and if it fails, raises that exception... with no further info.

> It may well be the case that the VideoCapture maintainers would have
> a pretty good idea of what might cause this error. That could push

Already tried this before posting to the Zope list. The author,
unfortunately, said he had no idea, and had no time to fiddle with the
code anymore. Oh well. Honestly i don't have time to be fiddling with
my silly webcam these days either. <-: Would have been nice if it
"just worked"... or someone had a quick answer. oh well.

> http://aspn.activestate.com/ASPN/Cookbook/Python/Recipe/52215

If nothing else, i get this handy snippet out of all this. (-:

Tim Middleton | Cain Gang Ltd | There are a thousand hacking at the branches
x@veX.net     | www.Vex.Net   | of evil [but who] at the root. --Thoreau (W)