[Zope] DateTime Error-Recurring

Zope@Stylus zope@stylusinc.net
Wed, 5 Mar 2003 12:47:05 +0530

Hi all

There is one  issue I would like to clarify.The date time module is throwing
an erro everytime I open the ZMI.
I have a zsql mehtod ...> select DateTime(ldate) from tbluser
Now as long as the ZMI is not opened there is no issue with the
performance.But at any point of time if I open the ZMI for doing some
editing then I get the following error.

      Zope Error
      Zope has encountered an error while publishing this resource.

      Error Type: Invalid Date-Time String
      Error Value: 2002-10-24 12:01:35+05


      Troubleshooting Suggestions

        a.. The URL may be incorrect.
        b.. The parameters passed to this resource may be incorrect.
        c.. A resource that this resource relies on may be encountering an
      For more detailed information about the error, please refer to the
HTML source for this page.

      If the error persists please contact the site maintainer. Thank you
for your patience.

Traceback (innermost last):
  File /Users/zope/Zope-2.5.1/lib/python/ZPublisher/Publish.py, line 150, in
  File /Users/zope/Zope-2.5.1/Products/Localizer/__init__.py, line 65, in
  File /Users/zope/Zope-2.5.1/lib/python/ZPublisher/Publish.py, line 114, in
  File /Users/zope/Zope-2.5.1/lib/python/Zope/__init__.py, line 159, in
    (Object: john)
  File /Users/zope/Zope-2.5.1/lib/python/ZPublisher/Publish.py, line 98, in
  File /Users/zope/Zope-2.5.1/lib/python/ZPublisher/mapply.py, line 88, in
    (Object: get_omslogs)
  File /Users/zope/Zope-2.5.1/lib/python/ZPublisher/Publish.py, line 39, in
    (Object: get_omslogs)
  File /Users/zope/Zope-2.5.1/lib/python/Shared/DC/Scripts/Bindings.py, line
252, in __call__
    (Object: get_omslogs)
  File /Users/zope/Zope-2.5.1/lib/python/Shared/DC/Scripts/Bindings.py, line
283, in _bindAndExec
    (Object: get_omslogs)
line 302, in _exec
    (Object: get_omslogs)
    (Info: ({'script': <PythonScript instance at 8e1ea08>, 'context':
<Folder instance at 8fa4a20>, 'container': <Folder instance at 8fa4a20>,
'traverse_subpath': []}, ('dd',), {}, None))
  File Script (Python), line 12, in get_omslogs
  File /Users/zope/Zope-2.5.1/lib/python/Shared/DC/ZRDB/DA.py, line 421, in
    (Object: zsqll_omslogs)
  File /Users/zope/Zope-2.5.1/lib/python/Products/ZPsycopgDA/db.py, line
205, in query
  File /Users/zope/Zope-2.5.1/lib/python/Products/ZPsycopgDA/DA.py, line
120, in cast_DateTime
  File /Users/zope/Zope-2.5.1/lib/python/DateTime/DateTime.py, line 651, in
  File /Users/zope/Zope-2.5.1/lib/python/DateTime/DateTime.py, line 1022, in
Invalid Date-Time String: (see above)

Thus erro only happens when the ZMI is opened.Now the solution for
overcoming this is still not clear .I open the detials of the Psycopg
connection and then click on the  Save changes
button without making any changes.And it seems to do the trick.But again
when someone opens the ZMI on their machine and I am already working n have
chnaged it but stil the same error gets thrown up.

Is this problem being faced only by me or others as well.The way I am
resolvin this issue is very non logical.Could you please guide me here and
point out where I may have gone wrong.Thanks for all help in advance

Thanks and Best Regards
John Kunchandy

Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.459 / Virus Database: 258 - Release Date: 2/25/2003