[Zope] Zope running only when started with -D from command line

Tobias Herp therp@apriori.de
Tue, 11 Mar 2003 15:09:52 +0100


I have a Win2K (test-) server running two instances of Zope, using 
different installations and the ports 8080 and 6080. Both were installed 
to run as Windows services. However, the 6080 version
(Zope 2.6.1 (binary release, python 2.1, win32-x86), python 2.1.3, 
win32) refuses to run unless called from command line (it has worked 
once upon a time, I think, but I can't tell what changed to disturb 
this). When the service is started, the pid file is in use, but no 
content is served. To Windows it looks like everything would be ok (the 
icons for stopping and restarting the service are active). When I stop 
the service and start Zope from command line, everything is ok.

I even tried to set Z_DEBUG_MODE for the the system to 'yes', but 
restarting the service still didn't work (well, the system didn't reboot 
since then... anyway the environment variables seem to be user specific, 
so they won't work without a logon).

There are no error messages whatsoever visible during Zope start. Where 
can I seek for the problem? Any ideas?