[Zope] Help: Finding/Deleting Bad Object from ZODB (Data.fs)

BZ bz@bwanazulia.com
Wed, 12 Mar 2003 07:40:56 -0600 (CST)

Ok... a clue.

I went into the debugger and all I saw was my current session opened.
Look at the cache detail I found the object:

1 '\x00\x00\x00\x00\x00\x01\xef\xce'      1 G

That is the object I am having problems with, but I have other Portal
Folders which are fine.

Another clue would be great...


> have you tried the debugger? you can find out more about the object
> that way. suppose you are in the debugger and the zope root is bound to
> app::
> app._p_jar['\x00\x00\x00\x00\x00\x01\xef\xce']
> that grabs the object "directly" and you might be able to find out more
> that way.
> jens
> On Wednesday, Mar 12, 2003, at 07:01 US/Eastern, BZ wrote:
>> I have been getting a POSKeyError when trying to list my Members
>> directory through the ZMI. I backed up everything packed the ZODB and
>> turned on debugging. Looks like there is a bad object.
>> When I run fstest.py:
>> 119583146L object serialno 0x034aab9e4b7e624c does not
>> matchtransaction id 0x034ac5e367948900
>> When I run it in debug mode I see it is this object:
>> \x00\x00\x00\x00\x00\x01\xef\xce
>> I grep'd on both of those things in my Data.fs but cannot find it.
>> So, how do I (or should I) delete that object?
>> BZ
>> _______________________________________________
>> Zope maillist  -  Zope@zope.org
>> http://mail.zope.org/mailman/listinfo/zope
>> **   No cross posts or HTML encoding!  **
>> (Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
>> http://mail.zope.org/mailman/listinfo/zope-dev )