[Zope] POSKeyError, help, please.

Stefan A. Nagey stefan@ispvip.biz
Sun, 23 Mar 2003 15:27:13 -0500

oh yea, and deleteing the objects in question is really not the 
preferred solution, because i would really rather not have to 
reconstruct the data from other means.

thank you in advance for imparting your vast wisdom to (on?) me.


On Sunday, Mar 23, 2003, at 15:23 US/Eastern, Stefan A. Nagey wrote:

> I've been struggling with this one non-stop since last night.
> I work at an ISP, we keep our customer records in zope.
> Somehow, i seem to have lost records for nearly 1/4 of our customers.
> I've tried deleting the index, packing the DB, exporting and then 
> importing into a fresh Data.fs, using fsrecover.py
> i've also tried fsrefs.py, which tells me that i'm missing a bunch of 
> objects.
> The size of my Data.fs is prettymuch unchanged, which might suggest 
> that the data is still there, but how do i get to it?
> What can I do that I haven't tried already, or, what have i messed up 
> that doing again will make all my worries go away.
> any help would be very much appreciated.
> thanks
> stefan
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> http://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
> http://mail.zope.org/mailman/listinfo/zope-dev )
Stefan A. Nagey
GSM: +1 (202) 415-0163