[Zope] Anyone else have this problem?

Terry Kerr terry@adroit.net
Fri, 28 Mar 2003 13:10:55 +1100


Just tried to install Zope-2.6.1 from src on my vanilla redhat7.1 system.  Its 
running python 2.1.1 (I know...I should upgrade)

It compiled, fine, but when I run I get this:

2003-03-28T12:41:48 PANIC(300) z2 Startup exception
Traceback (innermost last):
   File /home/zope/Zope-2.6.1-src/z2.py, line 582, in ?
   File /home/zope/Zope-2.6.1-src/lib/python/Zope/__init__.py, line 45, in startup
   File /home/zope/Zope-2.6.1-src/lib/python/Zope/App/startup.py, line 24, in ?
   File /home/zope/Zope-2.6.1-src/lib/python/ZODB/__init__.py, line 18, in ?
SystemError: _PyImport_FixupExtension: module ZODB.cPersistence not loaded

I did some simple imports, and discovered that cPersistence does infact import 
so long as ZODB.Timestamp is imported first.

Python 2.1.1 (#1, Nov 28 2001, 09:41:59)
[GCC 2.96 20000731 (Red Hat Linux 7.1 2.96-81)] on linux2
Type "copyright", "credits" or "license" for more information.
 >>> import ExtensionClass
 >>> import ZODB
Traceback (most recent call last):
   File "<stdin>", line 1, in ?
   File "/home/zope/Zope-2.6.1-src/lib/python/ZODB/__init__.py", line 18, in ?
     import cPersistence, Persistence
SystemError: _PyImport_FixupExtension: module ZODB.cPersistence not loaded
 >>> import ZODB.TimeStamp
 >>> import ZODB

So i simply added 'import TimeStamp' above 'import cPersistence' in 
ZODB/__init__.py and now Zope starts without problems.

I saw a few posts relating to this problem, but no solutions.  I tried 
compiling/running the same 2.6.1 source file on another linux system and didn't 
have any troubles!


Terry Kerr (terry@adroit.net)
Adroit Internet Solutions (www.adroit.net)
Phone: +61 3 9563 4461
Fax: +61 3 9563 3856