[Zope] pb upgrading Zope 2.5.0 -> 2.6.1

Nicolas LAURANCE nicolas.laurance@wanadoo.fr
Tue, 1 Apr 2003 00:23:51 +0200

 > ...
 > I have developped a website under zope 2.5.0, mostly w/ dtml a python
 > scripts.
 > It is based on zclass defined in products (not external products)
 > 3 of them were imported without pbs under Zope 2.6.1, but one of them
 > has nothing special), when I import it raises :
 > Error Type: ImportError
 > Error Value: No module named iclass

A well known problem with a known solution.

Please search the mailing list archives to find it.

> Yup. This was discussed about a week ago. Search the mailing
> list archives; but as I remember, only the ZClasses descended
> from ObjectManager have the problem, and then only if there
> is a non-empty list on the SubObjects tab. To export from
> 2.5.x, remove all from that list; then it will import fine
> into 2.6. Then, I presume that you can recreate the list of
> allowed subobjects, though I have not tried this.
> -- Jim Washington

Worked for me !!