[Zope] BTreeFolder2 issues

Dieter Maurer dieter@handshake.de
Thu, 15 May 2003 20:49:27 +0200

Sven Rudolph wrote at 2003-5-14 23:00 +0200:
 > we have the same problem on our production server.
 > This problem only appears (in our case) with object ids starting with a space.

I tried to reproduce this problem and, to my great surprise, I succeeded.

However, it turned out to be a bug in my browser ("Konqueror").
It drops leading spaces in submitted option values.

Maybe, your case is similar.

 > We have such a ghost object in our system since last spring. It can't be accessed, deleted, moved, exported or overwritten.

As the id is always wrong (missing leading whitespace), this can
be explained.

 > Also the the BTreeFolder containing this object can't be exported.

I can export my "BTreeFolder" without problem.

 > But I can loop over the subjects of this folder with an in-tag. In this case the ghost object doesn't appear in the loop...

I did not try but I am sure, the object will be there.

 > I think the problem is that the Object has allready been deleted but the id can't be removed from the list.

That might be the case, but I do not see why this might be possible.

When I worked around the browser bug, the object with leading space
was deleted without problem. No ghost object were created.
I use, however, an optimized "BTreeFolder" variant which make
no use of "_objects".

BTW: The URL spec forbids white space in URLs (to improve readability).