[Zope] Can't save Version in 2.6.1, please help!

Troy Farrell troy@entheossoft.com
Tue, 20 May 2003 16:07:52 -0500

Ken, did you pack your ZODB before you try to save or discard the 
version?  If so, I fear that you may have been bitten by this ZODB 
packing bug.  Your best shot atm may be to restore from backups...

If you did not, I don't really know what's wrong...


Ken Causey wrote:
> I know, I'm an idiot for using Versions, but they've worked reasonably
> well for me for a while and they are very handy for my situation
> allowing me to make modifications in the background and more or less
> instantaneously commit them for all to see.
> I have a Version I've been working in now for about 3 weeks.  I've
> modified and/or created around 50 new objects.  No matter what I do I
> can neither Save or Discard this version.  I've tried doing while
> working in the version, while not working in the version.  I've packed
> the database two or three times.  I've gone through and while working in
> the version I've resaved every single modified object.  Nothing I do
> will result in the version being saved.  At this point I've even tried
> to discard the version so it will free up the locks on the objects and
> even that won't work.
> I'm using Zope 2.6.1 with Python 2.1.3.  If there is any other
> information I can provide please let me know.  I'm getting desperate for
> a solution to this.  Help me this time and I swear I will never use
> Versions again.
> Ken Causey