[Zope] Working with sqlvar type=float

Mike Tran mtran at shufflemasterrd.com
Wed Oct 22 14:56:37 EDT 2003

Thanks for your suggestions.  getitem give me the error message below. Does
anyone else have anyother suggestion that could help me solve this? Thanks,

TypeError: expected string or Unicode object, ImplicitAcquirerWrapper found

----- Original Message ----- 
From: "Dieter Maurer" <dieter at handshake.de>
To: "Mike Doanh Tran" <mtran at shufflemasterrd.com>
Cc: <zope at zope.org>
Sent: Tuesday, October 21, 2003 2:10 PM
Subject: Re: [Zope] Working with sqlvar type=float

> Mike Doanh Tran wrote at 2003-10-20 13:58 -0600:
>  > I used the ZPublisher to convert a variable into a  type float(see
>  > field below).  I passed the variable "balance" to a ZSQL method where
>  > balance was set as type=float.  I keep getting an "invalid floating
>  > type error" when i called the updateBal ZSQ method. I even tried to
>  > convert balance with _.float(balance) but still get the same error.
>  > mysql db field for balance is set as type float.  Can someone help me
>  >
>  > <input type="text" name="rec.balance:float:ignore_empty:records"
>  > ---------------------------------
>  > <dtml-in rec mapping>
> The mapping may be wrong. A record exposes its content as attributes
> (although I am not sure whether you get it via "getitem", too).
> Dieter

More information about the Zope mailing list