[Zope] strange zope behavoir: zope not responding

Matthew Thorley ruach at chpc.utah.edu
Fri Oct 31 09:33:53 EST 2003

I have observed some strange behavior from two of my zope servers (ver 2.6.2) 
that I am unable to find a cause for. FYI both servers are running on intel 
boxes under redhat 9.0.

Case one;
When I start the server in debug mode everything appears to be fine. When I 
went to the servers url on port 8080 I see the default indexpage. When I 
click the link for the management section I get a dialog to log in. After 
entering the correct user and pass my browser attempts to load the management 
section and hangs. Generall it builds the frames for the page and loads the 
data for the header frame and the text for the left (navigational frame) but 
only empty (image-not-loaded-yet-icon) boxes where the images should be and I 
can see nothing in the main page frame.

If I restart the server the same thing happens. I also tried starting the 
server with these options -a ipaddress -Z1 -t 10 -f - -w - . 

After the page hangs it won't load(server?) the index page any more or any 
other page. My browser just sits there doing nothing until it times out with 
'document contained not data'

Case two 
After I start my server (different server then case 1) everything is fine and 
dandy for some time. I can create object, test objects and do normal zope 
stuff. At some point thought the server hangs, meaning any page I visit 
refuses to load and eventualy times out. At this point I can't even reload 
the page for objects that I am currently working on. The only thing that I 
remedies this is to restart zope.

Another thing that I have observed is that generaly speaking when the server 
gets to this stage, if I press ctrl+c to kill the server (in the window where 
it shows that it is running) It doesn't actualy kill the server. I don't get 
the messages:

2003-10-31T00:50:45 INFO(0) Z2 Closing all open ZODB databases
2003-10-31T00:50:45 INFO(0) Z2 Shutting down

It just dies silently.  But if I run ps aux | grep Zope it shows a Zope 
process running.

Does any one have any idea why this is happening ? or have you ever 
experienced this yourself?

thanks very much

More information about the Zope mailing list