[Zope] KeywordIndex Error and Startup Exception

Bert Vanderbauwhede bert.vanderbauwhede at ugent.be
Wed Feb 4 04:34:05 EST 2004


Last night, the Zope service on one of my servers has crashed. When I 
looked into the $STUPID_LOG_FILE, I found that a whole bunch of errors 
had happened during the day, first this one:

2004-02-03T12:49:18 ERROR(200) KeywordIndex unindex_object tried to
retrieve set 'wauw - systeem' from index Subject but couldn't.  This
should not happen.

And next several ones like this:

2004-02-03T13:59:03 ERROR(200) KeywordIndex unindex_object could not
remove documentId 1986485462 from index Subject.  This should not
Traceback (innermost last):
line 168, in removeForwardIndexEntry
(Object: Subject)
KeyError: 1986485462

I have cronjob running that creates a backup and packs Data.fs at 21:00.
This involves stopping and starting Zope. According to $STUPID_LOG_FILE,
this worked well. But later I got this:

2004-02-04T00:00:26 PANIC(300) z2 Startup exception
Traceback (innermost last):
File z2.py, line 497, in ?
File <string>, line 1, in ?
File /usr/src/redhat/BUILD/Zope-2.5.1-src/lib/python/Zope/__init__.py, 
line 37, in ?
line 213, in __init__
File /usr/src/redhat/BUILD/Zope-2.5.1-src/lib/python/ZODB/lock_file.py, 
line 33, in lock_file
StorageSystemError: Could not lock the database file.  There must be
another process that has opened the file.

This morning, after finding out, I could just restart Zope, as if
nothing had happened. I had the impression that about 20 documents had
disappeared, so I restored Data.fs from the backup I made yestarday


1. What were the KeywordIndex errors all about? Should I get worried?
2. Were the KeywordIndex errors the cause of the crash this night?

I use Python 2.1.3 and Zope 2.5.1, on RedHat 8.0.

Bert Vanderbauwhede...
"It is goot to shlay your enemies and listen to the
  lamen... lament... vat is dis vord here plis?"

More information about the Zope mailing list