[Zope] bug in xmlrpc

Jerry lists411 at myd1.com
Fri Feb 6 15:48:31 EST 2004

Hi Jerry,

I <J> wrote on Thursday (2/5/2004 at 18:24) thus about [Zope] bug in xmlrpc:
J> Hi Zopeople,

J> I upgraded to python 2.3 and now my program that calls routines via
J> XMLRPC is broken.  I am using the unmodofied xmlrpcBasicAuth module I
J> downloaded some time last year and code that worked fine on 2.2 now generates:

>>>> x=myserver.myfunction('xxx')
J> Traceback (most recent call last):
J>   File "<stdin>", line 1, in ?
J>   File "C:\app\Python23\lib\xmlrpclib.py", line 1029, in __call__
J>     return self.__send(self.__name, args)
J>   File "C:\app\Python23\lib\xmlrpclib.py", line 1316, in __request
J>     verbose=self.__verbose
J> TypeError: request() got an unexpected keyword argument 'verbose'

J> I don't see how I could be doing anything wrong, but if there was
J> something wrong with xmlrpclib.py I would think I would be able to
J> find something about it on zope.org or in the mailing lists.

J> I REALLY need to use XML-RPC with authorization for my program to
J> work.  Anyone have any fixes or suggestions?

More information: tried connecting to Zope 2.5.1 (which worked before)
and 2.6.1.  Always get the 'verbose' argument error.  Is no one else
calling their Zope site from Python with authentication?

BTW, I find it quite difficult to search on the "new" Zope.org, since
I can see no way of selecting by date range or type of object, and I
can only see 10 (mostly out of date and irrelevant links) per page.

Jerry      (Mailed safely with The Bat! 2.02.3 CE)
A closed mouth gathers no foot.

More information about the Zope mailing list