[Zope] setting Z_DEBUG_MODE

Jim Anderson ezjab at ieee.org
Tue Feb 24 13:47:18 EST 2004

I'm a newbie running Zope 2.7.0 on Linux.

I have some DTML problems and I'd like to get traceback
information on. Using tcsh, I ran
    setenv Z_DEBUG_MODE 1
and then ran 'runzope' in the same window after verifying
that Z_DEBUG_MODE is indeed set to 1.

When I run my sample code, I get an error message
in Zope that is shown at the end of this message.
With Z_DEBUG_MODE set, I was expecting to
get a traceback in the error message.  My expectation
was set from the chapter on debugging in the
"Zope Bible".


1) Did I understance the Zope Bible correctly, i.e.
the message below should have a traceback in it?

2) Did I do something wrong when setting up
the environment?

3) The error message refers to an error log. I checked
the log subdirectory in the directory where my zope instance
appears and could not find meaningful information about this
error there. Is there somewhere else to look?

4) If I misunderstood, how can I see a traceback?

Thanks in advance for any help.


_____________________________Error Message Starts 

    Site Error

An error was encountered while publishing this resource.

*Error Type: AttributeError*
*Error Value: Entries*


Troubleshooting Suggestions

    * The URL may be incorrect.
    * The parameters passed to this resource may be incorrect.
    * A resource that this resource relies on may be encountering an error.

For more detailed information about the error, please refer to the error 

If the error persists please contact the site maintainer. Thank you for 
your patience.

More information about the Zope mailing list