[Zope] Strange problem about Catalog

Dieter Maurer dieter at handshake.de
Thu Feb 26 14:14:52 EST 2004

Star War wrote at 2004-2-26 09:22 -0800:
>Actually I don't understand how "monkey patching"
>works, and i could not find a description in zope.org.
>I just put the folder 'ZopeProfiler' into the
>directory lib/python/products, then restart the
>zserver. ZopeProfiler did appear in ControlPanel, but
>the tabs are 'contents', 'properties','define
>permissions','undo', 'find', 'Readme', and 'Refresh'.
>And under contents, only help(ZopeProfiler). The
>version of Zope I used is 2.7. I also tried 2.6, the
>same result.

You look at the wrong place.

Apparently, you are looking at the "ZopeProfiler" product (!)
entry in "Control_Panel --> Product Management".

You should look at the "ZopeProfiler" instance (!)
in "Control_Panel" itself -- at its very bottom.
If there is not "ZopeProfiler" instance there,
something went wrong with the installation.
Activate Zope logging in this case and look into the logfile.


More information about the Zope mailing list